Support

Getting support

Premium support

Paid premium support is available as part of TinyMCE Enterprise and Tiny Cloud subscriptions. TinyMCE Enterprise customers can submit a case support request.

Community support

Open Source Community Edition users can get free help from Stack Overflow using the tinymce tag.

Supported Versions and Platforms

Supported TinyMCE versions

Supported versions of TinyMCE:

Version Release Date End of Support

6.7

2023-09-13

2025-03-13

6.6

2023-07-19

2025-01-19

6.5

2023-06-21

2024-12-21

6.4

2023-03-29

2024-09-29

6.3

2022-12-08

2024-06-08

6.2

2022-09-26

2024-03-26

6.1

2022-07-13

2024-01-13

6.0

2022-04-07

2023-10-07

To view our Software License Agreements, visit:

Support for Partner Plugins is provided by Partner companies and is not the responsibility of Tiny Technologies, Inc.. For information on Partner Plugins, see: https://www.tiny.cloud/partners/.

Supported web browsers

TinyMCE uses advanced JavaScript techniques to normalize inconsistencies among browsers to ensure a uniform user experience. The primary focus is on:

  • Google Chrome

  • Mozilla Firefox

  • Microsoft Edge

  • Apple Safari

TinyMCE may not function as expected on unlisted browsers. Try out the TinyMCE examples on https://www.tiny.cloud to determine any functional limitations of an unlisted browser.

Supported web browsers table

Browser Windows macOS GNU/Linux

Chrome (current version)

Chrome (penultimate version)

60 days

60 days

-

Chrome Extended stable (current version)

Firefox (current version)

Firefox (penultimate version)

60 days

60 days

60 days

Firefox ESR (current version)

Edge (current version)

-

-

Edge (penultimate version)

-

-

Safari (current version)

-

-

Safari (penultimate version)

-

-

Notes on the supported web browsers table.

  1. Penultimate version is defined as the most-recent-but-one major version of the listed browser.

    1. And major version is defined as a change to the whole number portion of a browser’s version number.

      1. For example Google Chrome 110 is the major version release that supercedes Google Chrome 109. So long as Google Chrome 110 is the current version, Google Chrome 109 will be the penultimate version.

  2. The 60 days of support for penultimate versions begins as of the release of the current version. Once a current browser release is more than 60 days old, TinyMCE is no longer supported on the penultimate version.

  3. TinyMCE is supported on the most recent update of the browsers listed above, on the operating systems listed above.

  4. TinyMCE is not supported on browsers running in Quirks or backward compatibility modes.

  5. TinyMCE is not supported on pre-release, beta, or other ‘technology preview’ browser releases.

  6. On browsers that offer a longer-term stable version (ie Firefox Extended Support Release and Chrome Extended stable), TinyMCE is only supported on the current longer-term stable release.

Supported Mobile Platforms

TinyMCE mobile is tested against, and is designed to run on, the default browser running on either the current or penultimate version of either Android and iOS.

Operating System Default browser

Android

Chrome

iOS

Safari

By default, both Google and Apple automatically update their operating systems and their default browsers.

Android and iOS, again by default, automatically update themselves with patches, security fixes, and minor updates. However, major updates — that is updates from one major version of the operating system to the next major version — are announced but not installed without user or system administrator input.

The default browser on each operating system is similarly updated with patches, security fixes, and minor updates. Unlike with the operating system, however, major updates — that is updates from one major version of the default browser to the next major version — are also automatically installed by default.

Consequently, Tiny Technologies, Inc. only supports TinyMCE mobile on the most recent release of each of the four supported operating system and browser combinations.

That is, TinyMCE mobile is supported on

  • the most recent release of the current version of Android in combination with the most recent release of Chrome for the current version of Android;

  • the most recent release of the penultimate version of Android in combination with the most recent release of Chrome for the penultimate version of Android.

  • the most recent release of the current version of iOS in combination with the most recent release of Safari for the current version of iOS.

  • the most recent release of the penultimate version of iOS in combination with the most recent release of Safari for the the penultimate version of iOS.

However, TinyMCE mobile is not supported on any beta or other pre-production releases of either the mobile operating system or its default browser.

Visit TinyMCE mobile documentation for information on TinyMCE mobile setup and configuration.

Premium plugin support information

Supported Premium Plugins

The following list of premium plugins are supported by Tiny Technologies, Inc. for TinyMCE 6.6:

TinyMCE’s Real-time Collaboration (RTC) plugin will be retired and deactivated on December 31, 2023, and is no longer available for purchase.

PowerPaste support (Copy and Paste)

This section details supported use of the Tiny PowerPaste plugin.

Pasting from Microsoft Word

Tiny Technologies, Inc. tests and supports using the PowerPaste plugin for copying content from versions of Microsoft Word and Microsoft Excel:

Pasting from Google Docs

Tiny Technologies, Inc. tests and supports using the PowerPaste plugin for copying content from Google Docs for:

  • Copying content from the latest version of Google Docs.

  • Pasting into any supported version of TinyMCE using PowerPaste 5.5.0 or later.

The following may work, but is not officially supported:

  • Copying content from other Google suite applications such as Google Sheets into TinyMCE.

PowerPaste Feature and Browser Support

PowerPaste (Copy and Paste) is supported on all the browsers supported by TinyMCE Enterprise. There are some variances of functionality for different browsers.

HTML Cleaning Improved HTML Cleaning Image Import

Microsoft Edge Latest

Chrome Latest

Firefox Latest

Safari Latest

HTML Cleaning

On all browsers, PowerPaste provides basic HTML cleaning. For browsers where HTML5 support is not available, PowerPaste uses the browser DOM to import and clean HTML. This mechanism is the primary cleaning method on browsers where HTML5 clipboard APIs are not available. While the resulting content is clean HTML the direct conversion to a browser DOM can result in some loss of content structure and/or formatting information.

Improved HTML Cleaning

On browsers that support HTML5 APIs, PowerPaste is able to use improved HTML cleaning techniques. Improved HTML cleaning uses the HTML5 clipboard APIs to access the clipboard directly. The original document structure and formatting (when importing formatting) is more likely to be preserved. Where available this approach gives the highest fidelity copy and paste from supported applications to HTML.

Image Import

On browsers that support HTML5, PowerPaste is able to import images embedded in the content (e.g. from Microsoft Word) into the editor. These images can then be uploaded via a HTTP post as required.

Supported Application Servers: Self-hosted Enterprise

The TinyMCE spell checking server-side component requires a Java Web Application Server that supports Servlet Implementation API 3.0.

Java Development Kit
  • JDK 8

Java (J2EE) Application Servers
  • Eclipse Jetty:

    • 9.4+

  • WebSphere Application Server (WAS) 8 or later

  • Apache Tomcat:

    • 10 (See note below)

    • 9+

    • 8.5.12+

    • 8.0.42+

    • 7.0.76+

    Tomcat 10 will require WAR files to be placed in the webapp-javaee directory rather than the webapps directory due to the change to Jakarta servlets. Jetty 11 is not currently supported due to this change.
Operating Systems
  • Windows Server 2008 SP2

  • Red Hat Enterprise Linux v6

  • Red Hat Enterprise Linux v5

Minimum Hardware Requirements
  • CPU: Dual Core Processor ~ 2Ghz. For higher loads, a quad core or higher is recommended.

  • RAM: 4 Gigabytes of RAM available for services