Tiny Logo
14-day Cloud trial
Start today. For free.

One editor. 50+ features. Zero constraints. After your trial, retain the advanced features.

Try Professional Plan for FREE
PricingContact Us
Log InGet Started Free

TinyMCE 5 Long Term Support (LTS)

Stay secure on TinyMCE 5

No more security patches, bug fixes, or new features will be introduced to TinyMCE 5, now that it's reached End of Support.

If moving to TinyMCE 6 isn't possible right now, sign up for TinyMCE 5 LTS to get ongoing critical security patches until you upgrade.

Request more details
Long Term Support

Why TinyMCE 5 Long Term Support (LTS)?

You need more time to upgrade to TinyMCE 6

Reason 1

Heavy customization

You've customized TinyMCE 5 to the point where it requires above-average effort to upgrade

Reason 2

Fixed release cycles

You have fixed release cycles, prohibiting you from upgrading components outside predetermined timeframes

Reason 3

Resource availability

Your team is busy with strategic projects that have higher priority than updating software components

What’s included in TinyMCE 5 Long Term Support?

Padlock icon

Critical security updates

Exclusive access to TinyMCE 5 security fixes as they're released, until at least the end of 2025

Compatibility icon

Plugin compatibility guarantee

A guarantee that security fixes won’t break supported TinyMCE 5 plugins when upgrading

Enterprise-grade support icon

Enterprise-grade support

Access to a dedicated support team, to help troubleshoot upgrade issues

How TinyMCE 5 Long Term Support (LTS) works

Receive immediate access to TinyMCE 5 security
updates as they're released

Step 1

Sign up for TinyMCE 5 LTS

Step 2

Receive your TinyMCE 5 LTS license key and include it in your config

Step 3

Receive email notifications as security fixes are available

Step 4

Upgrade TinyMCE 5 to the latest, most secure version

Keep your application secure with TinyMCE 5 LTS

Get peace of mind that you're running the most secure version of TinyMCE 5.

LTS includes:

  • Critical security updates, ongoing
  • Plugin compatibility guarantee
  • Enterprise-grade support

TinyMCE 5 LTS is in pre-release, and we're currently gathering market feedback to gauge demand. Fill out this form to express your interest in LTS, and we'll reach out with more information and pricing details.

I’m interested

FAQ

What is TinyMCE 5 Long Term Support (LTS) and where can I get it?

TinyMCE Long Term Support (LTS) gives you access to an exclusive version of TinyMCE 5 that comes with ongoing security updates. (Note: LTS is currently in pre-release).

The LTS Package is the only version of TinyMCE 5 that has access to essential security fixes.

For more information, please fill out the form on this page.

What does ‘in pre-release’ mean for TinyMCE 5 LTS?

Customer feedback suggests that an LTS version of TinyMCE 5 would be helpful, to give them more (secure) time to upgrade to TinyMCE 6. This pre-release phase is measuring interest among the community and our customer base – before deciding whether or not to proceed with offering a TinyMCE 5 LTS.

What is the official launch date of TinyMCE 5 LTS?

This pre-release phase is measuring interest among the community and our customer base – before deciding whether or not to proceed with offering a TinyMCE 5 LTS Package.

If it proceeds, a formal TinyMCE 5 LTS offering will be available for purchase by the end of 2023.

Is there a cost associated with TinyMCE 5 LTS?

Yes, there is a cost to access TinyMCE 5 LTS. For additional information, please fill out the form on this page.

What's the difference between TinyMCE 5, TinyMCE 5 LTS, and TinyMCE 6?

TinyMCE 5 has reached End of Support. TinyMCE 5 LTS is specifically designed for applications that require more time to transition to TinyMCE 6. It offers critical security updates and enterprise-grade support, unlike TinyMCE 5, which is no longer receiving updates. TinyMCE 6 is the latest version of TinyMCE and continues to receive regular security updates. For information on how to upgrade, visit this page.

Does TinyMCE 5 LTS Package come with support?

Yes. You have access to our enterprise-grade support when you sign up for TinyMCE 5 LTS.

How do I know when a new version of TinyMCE 5 Long Term Support (LTS) is released?

When a new TinyMCE 5 LTS version is released, an email notification is sent to the email address registered under your TinyMCE account.

When a TinyMCE 5 Long Term Support (LTS) version is released, will existing plugins continue to work and be supported?

Yes. When an LTS version is released, all official plugins (Premium and Free) will be tested for compatibility.

Can I customize TinyMCE 5 LTS like I did with TinyMCE 5?

Yes, TinyMCE 5 LTS will be easily customizable, just like TinyMCE 5. It's designed to be a smoother transition for those who have made extensive customizations.

How long will TinyMCE 5 LTS be supported?

We plan to support TinyMCE 5 LTS at least until the end of 2025.

Can I continue using TinyMCE 5?

Yes, you can continue using TinyMCE 5. But if you stay on an unsupported version of TinyMCE 5, you need to be aware that future security vulnerabilities may arise.

TinyMCE 5 Long Term Support (LTS) provides security updates for TinyMCE 5 until you decide to upgrade. (Note: LTS is currently in pre-release)

For more information, please fill out the form on this page.

What if I can’t upgrade to TinyMCE 6?

You may not be able to immediately upgrade to the latest version of TinyMCE because of customizations done to the editor, or lack of developer availability to perform the upgrade.

If that’s the case, TinyMCE 5 Long Term Support (LTS) provides security updates for TinyMCE 5 until you decide to upgrade. (Note: LTS is currently in pre-release)

For more information, please fill out the form on this page.

What is TinyMCE?

TinyMCE is a WYSIWYG software component that enables rich text editing capabilities in any application.

It’s used by millions of apps to allow users to create rich content – similar to Microsoft Word or Google Docs.

See TinyMCE in action →

Screenshot showing the TinyMCE editor

How do I know what version of TinyMCE I’m using?

1. Visit a page where the TinyMCE editor is running
2. Open up developer tools in your browser (instructions: Chrome, Firefox, Safari, Edge)
3. Open the “console” tab or menu item (varies by browser)
4. Type in the command tinymce.majorVersion and press enter
5. The major version (e.g. 4, 5 or 6) will be shown. If you’re on version 6, there’s no need to upgrade.

Chrome screenshot:Screenshot showing the Chrome devtools

Tiny logo

Stay Connected

SOC2 compliance badge

Products

TinyMCEDriveMoxieManager
© Copyright 2024 Tiny Technologies Inc.

TinyMCE® and Tiny® are registered trademarks of Tiny Technologies, Inc.